1. Welcome to Skyrim Forums! Register now to participate using the 'Sign Up' button on the right. You may now register with your Facebook or Steam account!
    Dismiss Notice

PS4 Stormcloaks/legion won't garrison forts?

Discussion in 'General Skyrim Discussion' started by Mithradates, Jan 6, 2020.

  1. Mithradates

    Mithradates Member

    Joined:
    Jan 2, 2018
    Messages:
    52
    Likes Received:
    8
    Reputation:
    9
    Each hold in Skyrim has one designated military fort that, if you clear it, is supposed to come under occupation by whichever side controls the hold. But for me, this just hasn't been happening. At least not as much as it should.

    This is actually mainly about the Stormcloaks, as that's who I'm playing right now and have played the last few times, but I think it applies just as well to the legion. I don't think I've really paid as much attention to the legion forts when I've played legion, because three of the designated legion forts (Sungard, Hraggstad, Neugrad) are quite out-of-the-way and not sitting right on the road like the Stormcloak forts are (though I do seem to recall a time in which I played legion and Fort Hraggstad didn't come under legion occupation even after Legate Rikke specifically sent me to clear it). The Stormcloak forts (Greenwall, Kastav, Amol, Dunstad) are more of a problem because two of them are close to the road and two of them are literally on top of it, and any bandits or mages that occupy them will attack you as you pass by. The only legion fort like this is Snowhawk in Hjaalmarch; the rest are far enough off the road that they can be safely ignored. When I play Stormcloak, I try to clear all the Stormcloak forts, but when I play legion, I only really bother with Snowhawk (as, when you play legion, you get all the Stormcloak forts anyway when you take them in the civil war quest line). Greymoor of course goes to the legion or Stormcloaks automatically upon the Battle of Whiterun.

    In my previous run recently, I cleared Fort Greenwall (always a priority as it sits on top of the road out of Riften), and the Stormcloaks then garrisoned it. All well and good. Then I tried clearing Fort Kastav. The Stormcloaks wouldn't take it. They're supposed to, and they have sometimes in previous runs, but this time they wouldn't. Every time I went past there it would be occupied by mages again. I'd clear it again and again and the Stormcloaks would never garrison it. It's not game-breaking or anything but it is rather annoying.

    I searched this site, the UESP site, and the Skyrim sub on Reddit, hoping to find helpful info on this issue, but as far as I could tell, I seem to be the only person on Earth with this problem. I tried posting a thread on Reddit asking about it, but I got no helpful answers, and I even got downvoted for some reason, I don't know why. Finally I just decided to start a new game and see what I could do.

    So, now I'm on my current run. Again I've chosen to go Stormcloak, so I'm clearing designated Stormcloak forts before actually joining the war. My order of priority is: 1, Greenwall; 2, Kastav; 3, Amol; and 4, Dunstad.

    I thought maybe the mechanic might have been broken by the fact that I had already joined the war last time and the Stormcloaks took over Fort Greymoor after the Battle of Whiterun. I thought maybe that caused the Stormcloaks to no longer take their own forts for some reason. So, without actually joining the Stormcloaks yet, I went and cleared Fort Greenwall, and the Stormcloaks took it. So far so good. I waited until confirming that the Stormcloaks were occupying Fort Greenwall, and then I went to clear Fort Kastav. I cleared it, then waited a while and, just now, went back to check if it had been garrisoned. It had not. It's occupied by skeletons and mages again.

    Even though I haven't joined the war, the legion hasn't taken any forts, and the Stormcloaks have only taken Greenwall so far, I can't get the Stormcloaks to take Kastav. But they have taken Kastav for me in previous games. I can't figure out why this works sometimes and not others.

    So I have a few questions.

    1. Does anyone else have this problem?
    2. Why does getting the Stormcloaks/legion to garrison their designated forts work some of the time but not others? Why can I sometimes get the Stormcloaks to occupy Kastav but not others? And while I've gotten them to occupy Greenwall this time, there have been other games in which I couldn't get them to do it. Is it totally random or is there a reason for this? What factors go into it, if any? Does joining or not joining the war affect it at all?
    3. Is this a problem unique to console games such as the PS4 version I'm playing, or does the PC version have it too?
    4. If a fort doesn't become garrisoned the first time you clear it, is it just permanently like that and it will never become garrisoned no matter how many times you try in that particular playthrough, or is it possible for it to become garrisoned on the second/third/fourth/etc time you clear it?
    5. Is there a specific number of forts the AI will garrison outside of the civil war questline? Like will they only do one, or two? I'm 90% sure I've gotten them to garrison at least two in the past, but I could be wrong.
     
  2. JoeReese

    JoeReese Well-Known Member

    Joined:
    Sep 14, 2012
    Messages:
    2,566
    Likes Received:
    1,268
    Reputation:
    1,838
    I suspect you're missing a boss, and the forts aren't registering as "cleared." For example, Fort Dunstad has a captain's quarters upstairs, above the main entry. It's very easy to miss (I have several times) and they won't garrison the fort until you dispose of the bandit boss in there. There are also prisons to remember. If you have a persistent problem fort, go through it again and make a point of opening every door and killing everything. Once done, you should see some troops on your next visit.
     

Share This Page

  • Like us on Facebook