1. Welcome to Skyrim Forums! Register now to participate using the 'Sign Up' button on the right. You may now register with your Facebook or Steam account!
    Dismiss Notice

HELP - Script Auto Parameter is Null

Discussion in 'Skyrim Creation Kit' started by FullArmor777, Jul 19, 2021.

  1. FullArmor777

    FullArmor777 New Member

    Joined:
    Jun 24, 2021
    Messages:
    2
    Likes Received:
    0
    Reputation:
    0
    Hello, All! I am a long time software developer but new to Skyrim modding. To help me learn I am attempting to create a test ring that adds gold to the player whenever they equip it. I will not be using it in game but it is just a simple test object that exercises several aspects that I am learning.

    I have created the script with OnEquipped and OnUnequipped event handlers and verified that the script does run. I've attached the script to the test ring and set up the parameters (see screen grabs for the params and test script below). The problem is that the auto parameter is null when the script runs. I've looked at this for days and for the life of me I can't figure out what I've done wrong. I would very much appreciate other more experienced eyes looking for what I've done wrong. I expect it is something simple and (dragon) boneheaded but I'm missing it. Thanks!

    Test Ring Object Script Parameters:

    Creation Kit - Test Ring.JPG

    Test Ring Script:

    Script - Test Ring.JPG
     
  2. FullArmor777

    FullArmor777 New Member

    Joined:
    Jun 24, 2021
    Messages:
    2
    Likes Received:
    0
    Reputation:
    0
    My issue has been resolved. Apparently there was nothing wrong with my object or script. I apparently had a save that had it already previous equipped. A new save with the test ring worked perfectly. :)
     

Share This Page

  • Like us on Facebook