1. Welcome to Skyrim Forums! Register now to participate using the 'Sign Up' button on the right. You may now register with your Facebook or Steam account!
    Dismiss Notice

PS3 Forsworn conspiracy glitch

Discussion in 'Skyrim Help' started by Samilya, Jul 19, 2020.

  1. Samilya

    Samilya New Member

    Joined:
    Jul 19, 2020
    Messages:
    2
    Likes Received:
    0
    Reputation:
    0
    Hello everyone

    I am playing skyrim for over 3 years now on ps3. In the first year I ran into this glitch and today I am trying to finish the quest. Grr..

    So at the shrine of Talos eltrys is dead and there are no guards. In the past I ran into them and I killed them off every time. Now I have no idea if it's because of that they don't reappear.

    What I've tried:
    - grabbed his body and tried to place at the marker
    - waited for 24 hours for guards
    Then another 10
    Still no guards
    - petty theft to serve time in the mine

    This was all I could find to try out and nothing moved the quest.

    Anyone suggestions?

    Also
    I can't finish the objective find out who N is, although I have Weylin's note.

    It would be nice to finally finish this one, as it also helps me to get rid of quest items
     

Share This Page

  • Like us on Facebook