1. Welcome to Skyrim Forums. You totally should register so you can experience everything our community offers. We have various resources related to Skyrim which include a massive array of Guides and Tutorials. If you're here just for the discussion you can check out our General Skyrim Discussion section or if you're here for help you can check out our Skyrim Help section. We also have the latest Skyrim News and fun stuff like Roleplaying and even a Skyrim Fan Fiction section!

    Are you here to discuss Dawnguard? You may discuss it by signing up and checking out this section.

    So if you love Skyrim you should join for sure. Click the 'Sign Up' button on the right to register your account. You can register with your Facebook or Steam account.

PC Users with Lag Issues

Discussion in 'General Skyrim Discussion' started by Pibbs, Nov 24, 2011.

  1. Pibbs New Member

    Member Since:
    Nov 24, 2011
    Message Count:
    9
    Reputation:
    0
    I feel the need to post here because my game went from unplayable to addictively fun in no time. The default settings of the game for PC are really laggy, especially the mouse, these changes will take your lag away for good!


    Quoted from the video:
    Step 1:
    -update skyrim to version 1.1
    (fixes mouse sensitivity issues in the menus)

    Step 2:
    -if you are not playing on gamepad, go to skyrim "gameplay" options and disable "360"
    (removes a lot of input lag)

    Step 3:
    -go to your video driver control panel and set "frames rendered ahead" to "1"
    (removes a lot of input lag)

    Step 4:
    -go to "Skyrim/skyrim/skyrimprefs.ini" and set "bMouseAcceleration" to "0"
    (disables sluggish skyrim mouse acceleration)

    Step 5:
    -go to "my documents/my games/skyrim/skyrim.ini" and add "iPresentInterval=0" to the [display] section
    (disables vsync, very important for all following tweaks)

    Step 6:
    -download "D3D_Antilag_v1.1" (http://www.skyrimnexus.com/downloads/file.php?id=34#content) and move "D3D9.dll" and "antilag.cfg" into the game folder (where the *.exe files are located)
    -open antilag.cfg with notepad and set "frames rendered ahead" to "1"
    (This forces frames rendered ahead to 1 and adds a framelimiter, which is required to fix vertical sensitivity issues)

    Step 7:
    -open antilag.cfg with notepad and change "FPSlimit" to "50"

    Step 8:
    -go to "my documents/my games/skyrim/skyrim.ini" and add:
    [Controls]
    fMouseHeadingYScale=0.0132
    fMouseHeadingXScale=0.0200
    (this syncs vertical and horizontal sensitivity for the FPS limit we have just set)

    Step 9:
    -change your skyrim video settings so that performance never drops below 40 fps
    (vertical sensitivity depends on it!)

    Step 10:
    -mouse sensitivity fine tuning: open "my documents/my games/skyrim/skyrimprefs.ini" and set "fMouseHeadingSensitivity" to your desired value
    (dont touch the sensitivity slider in the game options after doing this!)

    other tweaks:
    -to change fov, open console ingame and type "fov 90" (open console with the tilda button)
    or open "skyrim.ini" and add "fDefaultFOV=90.0" to the [general] section

    Thanks Killatomate85!

    Keep a copy of the two edited versions of your skyrim.ini and skyrimprefs.ini files so if they change to default again you don't have change the codes all over again. Hope that helps!

    Good luck!
  2. SkyrimGivesGraphgasms Member

    Member Since:
    Nov 13, 2011
    Message Count:
    46
    Reputation:
    0
    Would this help with my game where when I'm running through the world, I lag? That's the only issue I have and am not sure if this would fix my problem.
  3. furfur nord

    Member Since:
    Nov 25, 2011
    Message Count:
    4
    Reputation:
    0
    i cant figure out the update to 1.1, the video driver controle panel, or how to set the skyrim video settings. heres my system info and video card specs, if you can tell me how i would greatly appreciate it. i did everything but the three i mentioned and its helped dramaticaly.

    Attached Files:

  4. Pibbs New Member

    Member Since:
    Nov 24, 2011
    Message Count:
    9
    Reputation:
    0
    SkyrimGivesGraphgasms: It's possible, but I don't know man, you'll have to try it yourself to find out. If it doesn't improve anything, you can just undo the changes you made.

    Furfur: Don't worry, it's already updated to 1.1, Steam will keep it updated for you. If you have your updated Radeon drivers, you should have Radeon control panel that you'll be able to find, you should be able to do some searching in the configurations to change the settings you need to.
  5. SkyrimGivesGraphgasms Member

    Member Since:
    Nov 13, 2011
    Message Count:
    46
    Reputation:
    0
    Can you give a more detailed explanation of how to find the control panel for your video card? And, in that control panel, can you change the video settings so they don't drop below 40 fps?

    Just an update. Lag has decreased by a lot, with just missing these couple steps. I still lag, but I can run farther without lag.
  6. Pibbs New Member

    Member Since:
    Nov 24, 2011
    Message Count:
    9
    Reputation:
    0
    Oh, I think I understand the question now.

    It's my understanding that adjusting your video settings so that the game doesn't drop below 40 fps isn't necessarily changing a file or setting in your video card control panel. It's more changing the settings on your game so that your machine can run it without lagging too much. You might just have to drop settings down to low and take a few things off.

    From what I've read, we have pretty similar specs, I run mine on "low" settings without antialiasing, anisotropic filtering, any of the "reflects", no decal quantity, low radial blur and shadow quality, and no FXAA. The game really looks fine and runs fine. You might be able to mix and match your settings though, mine is just bare minimum.
  7. furfur nord

    Member Since:
    Nov 25, 2011
    Message Count:
    4
    Reputation:
    0
    ok the lag stuff worked well. any ideas on how to cut out load time, withoutkilling graphics quality? i dropped everything to mini u and load time went away but game looked like crap. im stuck with20-30+ mins load time just going from one room to the next.

Share This Page

Users found this page by searching for:

  1. skyrim lag pc

    ,
  2. skyrim pc lag

    ,
  3. d3d antilag

    ,
  4. how to fix skyrim lag pc,
  5. skyrim lag fixes pc,
  6. lag skyrim pc,
  7. skyrim for pc lagging,
  8. how to fix controller input lag on a skyrim pc,
  9. skyrim forums lag fix,
  10. skyrim pc with xbox controller lag