1. Welcome to Skyrim Forums. You totally should register so you can experience everything our community offers. We have various resources related to Skyrim which include a massive array of Guides and Tutorials. If you're here just for the discussion you can check out our General Skyrim Discussion section or if you're here for help you can check out our Skyrim Help section. We also have the latest Skyrim News and fun stuff like Roleplaying and even a Skyrim Fan Fiction section!

    Are you here to discuss Dawnguard? You may discuss it by signing up and checking out this section.

    So if you love Skyrim you should join for sure. Click the 'Sign Up' button on the right to register your account. You can register with your Facebook or Steam account.

Load screen crash

Discussion in 'Skyrim Help' started by Lee, Feb 1, 2012.

  1. Lee Rasta-For-I

    Member Since:
    Jan 18, 2012
    Message Count:
    235
    Location:
    Babylon
    Reputation:
    1
    The following might help people avoid a crash related to entering Drangonsreach. It might have been my particular circumstances exactly that lead to the crashes or it might have been that I had two quests not fully completed at the same time. I dunno, but I post this in case it might be of help to somebody.

    Playing Skyrim last night and I had a quest to burgle a premise in Markarth. I did the job, but didn't immediately return to Vex who gave the quest. I then went to the Bannered Mare to see if the landlady had any jobs. She told me a giant needed sorting near Whiterun. I killed the giant and then went to Dragonsreach to collect the money from Brill. I tried to enter Dragonsreach, but the during the loading screen my game crashed.

    I thought this was a one off until I loaded the game again and the exact same thing happened. I was getting a bit concerned now. I reloaded the game yet again and went to a previous save (before either of the quests had been undertaken). This started me in the room of somebody's house. I tried to leave their house and the game crashed again. I can't remember if the quests had been given during that load though.

    I reloaded the game again from the point where both quests had been done, but I''d not returned to the quest givers. I then just went to Vex, got my money and headed off to Dragonsreach. I was apprehensive as I opened the door, but so relieved to see it load without crashing.

    I had no more problems then. It's strange how a sequence of certain events can cause a crash.

Share This Page

Users found this page by searching for:

  1. skyrim ctd on load

    ,
  2. skyrim crash on load

    ,
  3. skyrim crash on entering rooms