1. Welcome to Skyrim Forums. You totally should register so you can experience everything our community offers. We have various resources related to Skyrim which include a massive array of Guides and Tutorials. If you're here just for the discussion you can check out our General Skyrim Discussion section or if you're here for help you can check out our Skyrim Help section. We also have the latest Skyrim News and fun stuff like Roleplaying and even a Skyrim Fan Fiction section!

    Are you here to discuss Dawnguard? You may discuss it by signing up and checking out this section.

    So if you love Skyrim you should join for sure. Click the 'Sign Up' button on the right to register your account. You can register with your Facebook or Steam account.

Quest Liberation of Skyrim (at Falkreath) glitched? (Xbox360)

Discussion in 'Skyrim Help' started by Bizud, Feb 16, 2012.

  1. Bizud New Member

    Member Since:
    Feb 16, 2012
    Message Count:
    4
    Reputation:
    0
    Hi, I bought this game on release day and I've been enjoying the heck out of it. I haven't run into any glitches at all, until tonight.

    I joined the Stormcloaks. After "liberating" Whiterun, Ulfric sent me to "liberate" Falkreath Hold and that's what the quest screen says to do. I'm sitting here at the Falkreath Stormcloak camp and the quest marker is over top of Galmar Stone-Fist's head, and clairvoyance leads right to his ass, but he doesn't have anything important to say! I can ask what his reasons for joining the war are, or what the aim of the war is, but there's no option to proceed further in the quest!

    I want a fix. I'm on level 44 and spent the last two nights painstakingly levelling up my smithing and enchanting and decking my character out...starting a new character is not an option. I'll go play through Mass Effect 1 and 2 again if I can't continue with this character.

    It seems this quest line has more than one reported bug. Apologies if there is already a thread for this, but I couldn't find one that matched this issue exactly.

    Thanks.

    Edit: Based on some yahoo answers for similar glitches at different parts of the campaign to liberate skyrim where Galmar isn't doing his job, I'm going to walk allll the way from Windhelm through Ivorstead to the camp, and see if that works.

    UPDATE: Okay, it's working now! I took a walk through Eastmarch to blow off steam (lol) and approached the camp from Ivorstead, walked up to Galmar and...nothing. I was disappointed, but another tip from Yahoo! answers said to keep talking to him a few times. I backed out of the conversation, then talked to him again, then backed out...anyway, the fourth time I talked to him, the "Reporting in" option was there! VERY strange and I wish I knew exactly what I did, but I'm happy to proceed in any case! So this one's kinda solved! On to Fort Neugrad! :D

    Moral of the story: Perseverance + Yahoo! answers.
  2. ColleenG When in doubt, follow the fox.

    Member Since:
    Dec 29, 2012
    Message Count:
    710
    Reputation:
    127
    I've not had that one but I have one where the game tells me I liberated Falkreath hold successfully, yet the quest journal doesn't mark it as completed. I went back to the Stormcloak camp and Mr. Fist wasn't there. Checked my map, and it said to go back to Windhelm to talk to Ulfric. Ulfric, however, had nothing to say. The quest marker was pointed at his buddy. His buddy had nothing to say. But then the journal showed Falkreath completed, and that I should report back to Rolof. Rolof isn't at the camp. So I guess I'll check the freaking fort again. He wasn't there before, but maybe things are different now...ha, yep, now Rolof is there, the quest shows completed, and I'm supposed to go BACK AGAIN to the palace of the kings and have a conversation with Ulfric. Apparently jumping around the map fixed things, if that's of any consolation.
  3. Mannulus Article Writer

    Member Since:
    Jan 21, 2013
    Message Count:
    231
    Reputation:
    70
    Never had that happen to me when I first tried the Stormcloak quests. Strange, I would of thought that they fixed most of the bugs by now.

Share This Page

Users found this page by searching for:

  1. liberate falkreath hold

    ,
  2. liberate falkreath hold walkthrough

    ,
  3. liberation of skyrim liberate falkreath hold bug

    ,
  4. skyrim liberate falkreath no quest marker,
  5. my quest says ask galmar stone fist for orders but he doesnt say anything